aboutsummaryrefslogtreecommitdiff
path: root/tasks/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tasks/default.nix')
-rw-r--r--tasks/default.nix19
1 files changed, 8 insertions, 11 deletions
diff --git a/tasks/default.nix b/tasks/default.nix
index 9fbee61..e851c24 100644
--- a/tasks/default.nix
+++ b/tasks/default.nix
@@ -1,35 +1,32 @@
-{ ... }:
+{ pkgs ? import <nixpkgs> { }, ... }:
{
custom.tasks = {
- "bsc_edit" = {
+ bsc_edit = {
description = "Grid refinement BSc thesis editor";
directory = "~/university/documents/bachelor/arbeit";
- terminal = false;
command = "nix-shell --run 'nvim-qt --no-ext-tabline'";
};
- "bsc_shell" = {
+ bsc_shell = {
description = "Grid refinement BSc thesis shell";
+ type = "terminal";
directory = "~/university/documents/bachelor/arbeit";
- terminal = true;
command = "nix-shell --command fish";
};
- "bsc_view" = {
+ bsc_view = {
description = "Grid refinement BSc thesis PDF";
directory = "~/university/documents/bachelor/arbeit";
- terminal = false;
command = "evince build/main.pdf";
};
- "olb_edit" = {
+ olb_edit = {
description = "OpenLB editor";
directory = "~/projects/contrib/openlb";
- terminal = false;
command = "nix-shell --run 'nvim-qt --no-ext-tabline'";
};
- "olb_shell" = {
+ olb_shell = {
description = "OpenLB shell";
+ type = "terminal";
directory = "~/projects/contrib/openlb";
- terminal = true;
command = "nix-shell --command fish";
};
};