aboutsummaryrefslogtreecommitdiff
path: root/tasks/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tasks/default.nix')
-rw-r--r--tasks/default.nix23
1 files changed, 21 insertions, 2 deletions
diff --git a/tasks/default.nix b/tasks/default.nix
index e851c24..6966fd2 100644
--- a/tasks/default.nix
+++ b/tasks/default.nix
@@ -1,6 +1,15 @@
-{ pkgs ? import <nixpkgs> { }, ... }:
+{ pkgs, ... }:
-{
+let
+ mkShellDerivation = n: ps: pkgs.stdenvNoCC.mkDerivation rec {
+ name = n;
+ buildInputs = ps;
+ shellHook = ''
+ export NIX_SHELL_NAME="${name}"
+ '';
+ };
+
+in {
custom.tasks = {
bsc_edit = {
description = "Grid refinement BSc thesis editor";
@@ -29,5 +38,15 @@
directory = "~/projects/contrib/openlb";
command = "nix-shell --command fish";
};
+ cpp_shell = {
+ description = "Generic C++ shell environment";
+ type = "environment";
+ directory = "~/";
+ environment = mkShellDerivation "cpp-env" (with pkgs; [
+ cmake
+ gcc8
+ gdb cgdb
+ ]);
+ };
};
}