summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2018-09-21 17:49:51 +0200
committerAdrian Kummerlaender2018-09-21 17:49:51 +0200
commit0024a2ca7918be83ad812b02348cb49dd2ff2d57 (patch)
tree53e12738aa868fa7025083fd90df9ff0d524d8e9 /configuration.nix
parent7de3c3bee50247cd3a1102a5eab0d8ebb9ca0432 (diff)
downloadnixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.tar
nixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.tar.gz
nixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.tar.bz2
nixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.tar.lz
nixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.tar.xz
nixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.tar.zst
nixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.zip
Add basic automatix config
Extract desktop-specific settings that are shared by asterix and obelix into desktop role.
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix53
1 files changed, 5 insertions, 48 deletions
diff --git a/configuration.nix b/configuration.nix
index 3a4be5b..fef5b26 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -5,20 +5,10 @@
imports = [
./host/current.nix
+ ./conf/common.nix
./conf/fish.nix
];
- fileSystems."/".options = [ "noatime" "nodiratime" "discard" ];
-
- sound.enable = true;
- hardware = {
- opengl.driSupport32Bit = true;
- pulseaudio = {
- enable = true;
- support32Bit = true;
- };
- };
-
i18n = {
consoleKeyMap = "de";
defaultLocale = "en_US.UTF-8";
@@ -36,49 +26,16 @@
};
};
- services = {
- openssh = {
- enable = true;
- };
-
- journald = {
- extraConfig = ''Storage=volatile'';
- };
-
- openvpn.servers = {
- KIT = {
- config = import ./conf/vpn/kit.ovpn.nix;
- autoStart = false;
- };
- };
-
- xserver = {
- enable = true;
- layout = "de";
- xkbOptions = "caps:escape";
-
- displayManager.slim = {
- enable = true;
- autoLogin = true;
- defaultUser = "common";
- };
-
- desktopManager.default = "none";
- };
- };
-
- users.extraUsers.common = {
- isNormalUser = true;
- uid = 1000;
- extraGroups = [ "wheel" ];
- shell = pkgs.fish;
+ services.openssh = {
+ enable = true;
+ permitRootLogin = "no";
};
environment = {
systemPackages = let
custom_vim = import ./pkgs/vim/vim.nix pkgs;
in with pkgs; [
- hdparm ntfs3g psmisc htop fish git silver-searcher custom_vim
+ psmisc htop fish git silver-searcher custom_vim
];
shellAliases = {