summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2018-05-07 20:53:47 +0200
committerAdrian Kummerlaender2018-05-07 20:53:47 +0200
commit0f04ebeab7291fb39bba83a031d777947a8b18fd (patch)
tree1b5e3f9c24751b76149fec30430982cfbb67cbaa /configuration.nix
parent0dd401a70b5820b8991c0c3a62fd0661e2e463b5 (diff)
downloadnixos_system-0f04ebeab7291fb39bba83a031d777947a8b18fd.tar
nixos_system-0f04ebeab7291fb39bba83a031d777947a8b18fd.tar.gz
nixos_system-0f04ebeab7291fb39bba83a031d777947a8b18fd.tar.bz2
nixos_system-0f04ebeab7291fb39bba83a031d777947a8b18fd.tar.lz
nixos_system-0f04ebeab7291fb39bba83a031d777947a8b18fd.tar.xz
nixos_system-0f04ebeab7291fb39bba83a031d777947a8b18fd.tar.zst
nixos_system-0f04ebeab7291fb39bba83a031d777947a8b18fd.zip
Switch system to LUKS-encrypted SSD
As hoped redeployment consisted only of partioning the new drive, copying the config and calling `nixos-install`.
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix21
1 files changed, 17 insertions, 4 deletions
diff --git a/configuration.nix b/configuration.nix
index b318c58..8fcab2e 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -8,12 +8,25 @@
./conf/fish.nix
];
- boot.loader.grub = {
- enable = true;
- version = 2;
- device = "/dev/sda";
+ boot = {
+ loader.grub = {
+ enable = true;
+ version = 2;
+ device = "/dev/sdb";
+ };
+
+ initrd.luks.devices = [
+ {
+ name = "root";
+ device = "/dev/disk/by-uuid/6205da24-b1b2-402c-b175-4036e678dea9";
+ preLVM = true;
+ allowDiscards = true;
+ }
+ ];
};
+ fileSystems."/".options = [ "noatime" "nodiratime" "discard" ];
+
networking = {
hostName = "obelix";
firewall.enable = false;