summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2018-04-20 13:31:10 +0200
committerAdrian Kummerlaender2018-04-20 13:31:10 +0200
commit478ce7035ab7af733a0390b242affb656539f16d (patch)
treeae3c2f22d724f430a7bd34446252250c122a7616 /configuration.nix
downloadnixos_system-478ce7035ab7af733a0390b242affb656539f16d.tar
nixos_system-478ce7035ab7af733a0390b242affb656539f16d.tar.gz
nixos_system-478ce7035ab7af733a0390b242affb656539f16d.tar.bz2
nixos_system-478ce7035ab7af733a0390b242affb656539f16d.tar.lz
nixos_system-478ce7035ab7af733a0390b242affb656539f16d.tar.xz
nixos_system-478ce7035ab7af733a0390b242affb656539f16d.tar.zst
nixos_system-478ce7035ab7af733a0390b242affb656539f16d.zip
Start tracking system configuration
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix79
1 files changed, 79 insertions, 0 deletions
diff --git a/configuration.nix b/configuration.nix
new file mode 100644
index 0000000..1677d38
--- /dev/null
+++ b/configuration.nix
@@ -0,0 +1,79 @@
+{ config, pkgs, ... }:
+
+{
+ system.stateVersion = "18.03";
+
+ imports = [
+ ./hardware-configuration.nix
+ ./conf/fish.nix
+ ];
+
+ boot.loader.grub = {
+ enable = true;
+ version = 2;
+ device = "/dev/sda";
+ };
+
+ networking = {
+ hostName = "obelix";
+ firewall.enable = false;
+ };
+
+ sound.enable = true;
+ hardware = {
+ pulseaudio.enable = true;
+ opengl.driSupport32Bit = true;
+ };
+
+ i18n = {
+ consoleKeyMap = "de";
+ defaultLocale = "en_US.UTF-8";
+ };
+
+ time.timeZone = "Europe/Berlin";
+
+ nixpkgs.config.allowUnfree = true;
+
+ programs = {
+ bash.enableCompletion = true;
+ gnupg.agent = {
+ enable = true;
+ enableSSHSupport = true;
+ };
+ };
+
+ services = {
+ openssh = {
+ enable = true;
+ };
+
+ xserver = {
+ enable = true;
+ layout = "de";
+ xkbOptions = "caps:escape";
+
+ videoDrivers = [ "nvidia" ];
+
+ displayManager.slim = {
+ enable = true;
+ autoLogin = true;
+ defaultUser = "common";
+ };
+
+ desktopManager.default = "none";
+ };
+ };
+
+ users.extraUsers.common = {
+ isNormalUser = true;
+ uid = 1000;
+ extraGroups = [ "wheel" ];
+ shell = pkgs.fish;
+ };
+
+ environment.systemPackages = let
+ custom_vim = import ./pkgs/vim/vim.nix pkgs;
+ in with pkgs; [
+ ntfs3g htop fish custom_vim
+ ];
+}