summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2021-08-19 12:10:30 +0200
committerAdrian Kummerlaender2021-08-19 23:40:42 +0200
commita468935722b85beef588ab313f2adfe0159564e2 (patch)
tree1eae65d063843d6712a6a4d4d46546623d1f875e /configuration.nix
parent725db6480cbac8a8e9da1b527bd391ec3d64f5b6 (diff)
downloadnixos_system-a468935722b85beef588ab313f2adfe0159564e2.tar
nixos_system-a468935722b85beef588ab313f2adfe0159564e2.tar.gz
nixos_system-a468935722b85beef588ab313f2adfe0159564e2.tar.bz2
nixos_system-a468935722b85beef588ab313f2adfe0159564e2.tar.lz
nixos_system-a468935722b85beef588ab313f2adfe0159564e2.tar.xz
nixos_system-a468935722b85beef588ab313f2adfe0159564e2.tar.zst
nixos_system-a468935722b85beef588ab313f2adfe0159564e2.zip
Basic flakeification
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix37
1 files changed, 21 insertions, 16 deletions
diff --git a/configuration.nix b/configuration.nix
index 868d6cf..73138f6 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -1,13 +1,9 @@
-{ config, pkgs, ... }:
-
-let
- mypkgs = import <mypkgs> { };
-
-in {
+{ config, pkgs, pkgs-personal, hostname, ... }:
+{
imports = [
./fish.nix
- ./host/current.nix
./user/common.nix
+ (./host + ("/" + hostname + ".nix"))
];
console.keyMap = "de";
@@ -20,7 +16,16 @@ in {
nixpkgs.config.allowUnfree = true;
- nix.allowedUsers = [ "common" ];
+ nix = {
+ package = pkgs.nixUnstable;
+
+ allowedUsers = [ "common" ];
+ trustedUsers = [ "root" "common" ];
+
+ extraOptions = ''
+ experimental-features = nix-command flakes
+ '';
+ };
networking.nameservers = [
"1.1.1.1"
@@ -43,14 +48,14 @@ in {
};
environment = {
- systemPackages = [
- pkgs.psmisc
- pkgs.htop
- pkgs.git
- pkgs.p7zip
- pkgs.silver-searcher
- pkgs.renameutils
- mypkgs.custom-neovim
+ systemPackages = with pkgs; [
+ psmisc
+ htop
+ git
+ p7zip
+ silver-searcher
+ renameutils
+ pkgs-personal.custom-neovim
];
variables = {