summaryrefslogtreecommitdiff
path: root/fish.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2023-03-04 19:25:01 +0100
committerAdrian Kummerlaender2023-03-04 19:25:43 +0100
commit1b6444fa5b224938b477d0f970d228e346a29042 (patch)
treedf733697f74b30f3d83da7dcd61ecdb95534ebf7 /fish.nix
parentdf523e8222014da5a98edc88b73ab91a7f5f0d2a (diff)
downloadnixos_system-1b6444fa5b224938b477d0f970d228e346a29042.tar
nixos_system-1b6444fa5b224938b477d0f970d228e346a29042.tar.gz
nixos_system-1b6444fa5b224938b477d0f970d228e346a29042.tar.bz2
nixos_system-1b6444fa5b224938b477d0f970d228e346a29042.tar.lz
nixos_system-1b6444fa5b224938b477d0f970d228e346a29042.tar.xz
nixos_system-1b6444fa5b224938b477d0f970d228e346a29042.tar.zst
nixos_system-1b6444fa5b224938b477d0f970d228e346a29042.zip
Remove fish config in favor of userspace
Diffstat (limited to 'fish.nix')
-rw-r--r--fish.nix81
1 files changed, 0 insertions, 81 deletions
diff --git a/fish.nix b/fish.nix
deleted file mode 100644
index 4253b11..0000000
--- a/fish.nix
+++ /dev/null
@@ -1,81 +0,0 @@
-{ pkgs, ... }:
-
-{
- programs.fish = {
- enable = true;
-
- shellInit = ''
- set fish_greeting ""
- '';
-
- interactiveShellInit = ''
- eval (dircolors -c ${./asset/dir_colors})
-
- set fish_color_normal white
- set fish_color_command magenta --bold
- set fish_color_param green
- set fish_color_error brred
- set fish_color_operator cyan
- set fish_color_comment white
- set fish_color_cwd green
- set fish_color_quote brown
- set fish_color_autosuggestion 555
- set fish_color_redirection white
- '';
-
- promptInit = ''
- function fish_prompt
- if test $TERM = "dumb"
- echo "\$ "
- return 0
- end
-
- set last_status $status
-
- if not set -q __fish_prompt_normal
- set -g __fish_prompt_normal (set_color normal)
- end
-
- switch $USER
- case root
- if not set -q __fish_prompt_cwd
- if set -q fish_color_cwd_root
- set -g __fish_prompt_cwd (set_color $fish_color_cwd_root)
- else
- set -g __fish_prompt_cwd (set_color $fish_color_cwd)
- end
- end
-
- case '*'
- if not set -q __fish_prompt_cwd
- set -g __fish_prompt_cwd (set_color $fish_color_cwd)
- end
- end
-
- echo -n -s 'λ ' "$__fish_prompt_cwd" (prompt_pwd) "$__fish_prompt_normal"
-
- if test $IN_NIX_SHELL
- if test $name
- echo -n -s ' (' $name ')'
- else
- echo -n -s ' (nix-shell)'
- end
- end
-
- if test $last_status -gt 0
- set_color $fish_color_cwd_root
- echo -n -s ' • '
- set_color normal
- else
- echo -n -s ' • '
- end
- end
-
- function fish_right_prompt
- set_color $fish_color_autosuggestion
- date '+%H:%M:%S'
- set_color normal
- end
- '';
- };
-}