summaryrefslogtreecommitdiff
path: root/host/hardware/athena.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2021-05-11 21:19:18 +0200
committerAdrian Kummerlaender2021-05-11 21:19:18 +0200
commit7de9f38d87c16b76ef5d7c0cd7329d49b79b6c09 (patch)
tree26f9ca4b3272ff06951f3324cb67c49855a24f46 /host/hardware/athena.nix
parentd7915ad15070dda0aecaea294ce1acd42a21fb1c (diff)
downloadnixos_system-7de9f38d87c16b76ef5d7c0cd7329d49b79b6c09.tar
nixos_system-7de9f38d87c16b76ef5d7c0cd7329d49b79b6c09.tar.gz
nixos_system-7de9f38d87c16b76ef5d7c0cd7329d49b79b6c09.tar.bz2
nixos_system-7de9f38d87c16b76ef5d7c0cd7329d49b79b6c09.tar.lz
nixos_system-7de9f38d87c16b76ef5d7c0cd7329d49b79b6c09.tar.xz
nixos_system-7de9f38d87c16b76ef5d7c0cd7329d49b79b6c09.tar.zst
nixos_system-7de9f38d87c16b76ef5d7c0cd7329d49b79b6c09.zip
Update athena to new hardware
Diffstat (limited to 'host/hardware/athena.nix')
-rw-r--r--host/hardware/athena.nix16
1 files changed, 9 insertions, 7 deletions
diff --git a/host/hardware/athena.nix b/host/hardware/athena.nix
index b0fb576..4849b6f 100644
--- a/host/hardware/athena.nix
+++ b/host/hardware/athena.nix
@@ -1,31 +1,33 @@
# Do not modify this file! It was generated by ‘nixos-generate-config’
# and may be overwritten by future invocations. Please make changes
# to /etc/nixos/configuration.nix instead.
-{ config, lib, pkgs, ... }:
+{ config, lib, pkgs, modulesPath, ... }:
{
imports =
- [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+ [ (modulesPath + "/installer/scan/not-detected.nix")
];
- boot.initrd.availableKernelModules = [ "xhci_pci" "nvme" "usb_storage" "sd_mod" "rtsx_pci_sdmmc" ];
+ boot.initrd.availableKernelModules = [ "xhci_pci" "nvme" "usb_storage" "sd_mod" ];
+ boot.initrd.kernelModules = [ "dm-snapshot" ];
boot.kernelModules = [ "kvm-intel" "fuse" ];
boot.extraModulePackages = [ ];
fileSystems."/" =
- { device = "/dev/disk/by-uuid/a382b969-52d6-4946-ae8a-5da3f612410c";
+ { device = "/dev/disk/by-uuid/198fbcc1-0b72-4465-891a-5959c6bfcfc6";
fsType = "ext4";
};
fileSystems."/boot" =
- { device = "/dev/disk/by-uuid/CC5B-E0DA";
+ { device = "/dev/disk/by-uuid/6510-C4DF";
fsType = "vfat";
};
swapDevices =
- [ { device = "/dev/disk/by-uuid/96edaf95-23ce-4859-b82f-048711d2a8d2"; }
+ [ { device = "/dev/disk/by-uuid/60bd356a-c28e-4f5e-90ff-6331a3cb7252"; }
];
- nix.maxJobs = lib.mkDefault 4;
powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+ # high-resolution display
+ hardware.video.hidpi.enable = lib.mkDefault true;
}