summaryrefslogtreecommitdiff
path: root/host/hardware/majestix.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2020-12-04 16:13:58 +0100
committerAdrian Kummerlaender2020-12-04 16:13:58 +0100
commit328ced7972c58902fb60d8b7af31315b6a68d649 (patch)
tree47ce6309672ee42d9b2ba1bc5fe139f57b551f10 /host/hardware/majestix.nix
parentd3fc233ea582bf8ef30c3793ff05c74f2b48508a (diff)
downloadnixos_system-328ced7972c58902fb60d8b7af31315b6a68d649.tar
nixos_system-328ced7972c58902fb60d8b7af31315b6a68d649.tar.gz
nixos_system-328ced7972c58902fb60d8b7af31315b6a68d649.tar.bz2
nixos_system-328ced7972c58902fb60d8b7af31315b6a68d649.tar.lz
nixos_system-328ced7972c58902fb60d8b7af31315b6a68d649.tar.xz
nixos_system-328ced7972c58902fb60d8b7af31315b6a68d649.tar.zst
nixos_system-328ced7972c58902fb60d8b7af31315b6a68d649.zip
Update majestix for new hardware
Diffstat (limited to 'host/hardware/majestix.nix')
-rw-r--r--host/hardware/majestix.nix19
1 files changed, 9 insertions, 10 deletions
diff --git a/host/hardware/majestix.nix b/host/hardware/majestix.nix
index 5c78ed8..ff9d519 100644
--- a/host/hardware/majestix.nix
+++ b/host/hardware/majestix.nix
@@ -1,31 +1,30 @@
# Do not modify this file! It was generated by ‘nixos-generate-config’
# and may be overwritten by future invocations. Please make changes
# to /etc/nixos/configuration.nix instead.
-{ config, lib, pkgs, ... }:
+{ config, lib, pkgs, modulesPath, ... }:
{
imports =
- [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+ [ (modulesPath + "/installer/scan/not-detected.nix")
];
- boot.initrd.availableKernelModules = [ "xhci_pci" "ehci_pci" "ahci" "usbhid" "sd_mod" "sr_mod" ];
- boot.kernelModules = [ "kvm-intel" ];
+ boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "nvme" "usb_storage" "usbhid" "sd_mod" ];
+ boot.initrd.kernelModules = [ "dm-snapshot" ];
+ boot.kernelModules = [ "kvm-amd" ];
boot.extraModulePackages = [ ];
fileSystems."/" =
- { device = "/dev/disk/by-uuid/6eb9a8c7-0384-4c47-9e4e-24d2ed57fc2e";
+ { device = "/dev/disk/by-uuid/4587b5ba-be4d-453a-a95a-289be7612271";
fsType = "ext4";
};
fileSystems."/boot" =
- { device = "/dev/disk/by-uuid/e8a055f9-4293-4a55-9974-9ca39bf209cd";
- fsType = "ext2";
+ { device = "/dev/disk/by-uuid/D7EA-FB64";
+ fsType = "vfat";
};
swapDevices =
- [ { device = "/dev/disk/by-uuid/b27d07d6-bc07-4e7c-bd14-2b67c89dbf20"; }
+ [ { device = "/dev/disk/by-uuid/7237cb82-4c5e-4997-856a-20194ac1521c"; }
];
- nix.maxJobs = lib.mkDefault 8;
- powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
}