summaryrefslogtreecommitdiff
path: root/host/majestix.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2020-12-04 16:13:58 +0100
committerAdrian Kummerlaender2020-12-04 16:13:58 +0100
commit328ced7972c58902fb60d8b7af31315b6a68d649 (patch)
tree47ce6309672ee42d9b2ba1bc5fe139f57b551f10 /host/majestix.nix
parentd3fc233ea582bf8ef30c3793ff05c74f2b48508a (diff)
downloadnixos_system-328ced7972c58902fb60d8b7af31315b6a68d649.tar
nixos_system-328ced7972c58902fb60d8b7af31315b6a68d649.tar.gz
nixos_system-328ced7972c58902fb60d8b7af31315b6a68d649.tar.bz2
nixos_system-328ced7972c58902fb60d8b7af31315b6a68d649.tar.lz
nixos_system-328ced7972c58902fb60d8b7af31315b6a68d649.tar.xz
nixos_system-328ced7972c58902fb60d8b7af31315b6a68d649.tar.zst
nixos_system-328ced7972c58902fb60d8b7af31315b6a68d649.zip
Update majestix for new hardware
Diffstat (limited to 'host/majestix.nix')
-rw-r--r--host/majestix.nix37
1 files changed, 15 insertions, 22 deletions
diff --git a/host/majestix.nix b/host/majestix.nix
index da855d6..3d33aca 100644
--- a/host/majestix.nix
+++ b/host/majestix.nix
@@ -7,17 +7,18 @@
];
boot = {
- loader.grub = {
- enable = true;
- version = 2;
- device = "/dev/sda";
+ loader = {
+ systemd-boot.enable = true;
+ efi.canTouchEfiVariables = true;
};
- initrd.luks.devices = [ {
- name = "encrypted";
- device = "/dev/sda2";
- preLVM = true;
- } ];
+ initrd.luks.devices = {
+ encrypted = {
+ device = "/dev/nvme0n1p2";
+ preLVM = true;
+ allowDiscards = true;
+ };
+ };
};
networking = {
@@ -32,22 +33,10 @@
acpid.enable = true;
xserver = {
- videoDrivers = [ "intel" ];
- };
-
- printing = {
- enable = true;
- drivers = [ pkgs.brgenml1cupswrapper ];
- };
-
- avahi = {
- enable = true;
- nssmdns = true;
+ videoDrivers = [ "nvidia" ];
};
};
- hardware.opengl.extraPackages = [ pkgs.intel-ocl ];
-
networking.wireguard.interfaces = {
wg0 = {
ips = [ "10.100.0.3/24" ];
@@ -64,4 +53,8 @@
];
};
};
+
+ nix.maxJobs = 32;
+
+ system.stateVersion = "20.09";
}