summaryrefslogtreecommitdiff
path: root/host/majestix.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2018-12-17 11:57:32 +0100
committerAdrian Kummerlaender2018-12-17 11:57:32 +0100
commit423496f53509b82142af9c9c276f2c74204b62c1 (patch)
treec013d7426fac1b9c2726a8b94bc2f136155f6ede /host/majestix.nix
parent4e3825da58280e04c9393081a5c6efd581151c25 (diff)
downloadnixos_system-423496f53509b82142af9c9c276f2c74204b62c1.tar
nixos_system-423496f53509b82142af9c9c276f2c74204b62c1.tar.gz
nixos_system-423496f53509b82142af9c9c276f2c74204b62c1.tar.bz2
nixos_system-423496f53509b82142af9c9c276f2c74204b62c1.tar.lz
nixos_system-423496f53509b82142af9c9c276f2c74204b62c1.tar.xz
nixos_system-423496f53509b82142af9c9c276f2c74204b62c1.tar.zst
nixos_system-423496f53509b82142af9c9c276f2c74204b62c1.zip
Add majestix system config
Diffstat (limited to 'host/majestix.nix')
-rw-r--r--host/majestix.nix48
1 files changed, 48 insertions, 0 deletions
diff --git a/host/majestix.nix b/host/majestix.nix
new file mode 100644
index 0000000..8d5aab7
--- /dev/null
+++ b/host/majestix.nix
@@ -0,0 +1,48 @@
+{ pkgs, ... }:
+
+{
+ imports = [
+ ./hardware/majestix.nix
+ ./software/desktop
+ ];
+
+ boot = {
+ loader.grub = {
+ enable = true;
+ version = 2;
+ device = "/dev/sda";
+ };
+
+ initrd.luks.devices = [ {
+ name = "encrypted";
+ device = "/dev/sda2";
+ preLVM = true;
+ } ];
+ };
+
+ networking = {
+ hostName = "majestix";
+ firewall.enable = false;
+ networkmanager.enable = true;
+ };
+
+ users.extraUsers.common.extraGroups = [ "networkmanager" ];
+
+ services = {
+ acpid.enable = true;
+
+ xserver = {
+ videoDrivers = [ "intel" ];
+ };
+
+ printing = {
+ enable = true;
+ drivers = [ pkgs.brgenml1cupswrapper ];
+ };
+
+ avahi = {
+ enable = true;
+ nssmdns = true;
+ };
+ };
+}