summaryrefslogtreecommitdiff
path: root/host/obelix.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2019-06-22 23:46:13 +0200
committerAdrian Kummerlaender2019-06-22 23:46:39 +0200
commit62ec6992a6e553d34477f7edc90ac491d4606321 (patch)
tree0efa9af28f1e08c0e5d11888888eb12395115e23 /host/obelix.nix
parente481d7b2962e1e5dbe9a4ca10bfef91ba6c266f5 (diff)
downloadnixos_system-62ec6992a6e553d34477f7edc90ac491d4606321.tar
nixos_system-62ec6992a6e553d34477f7edc90ac491d4606321.tar.gz
nixos_system-62ec6992a6e553d34477f7edc90ac491d4606321.tar.bz2
nixos_system-62ec6992a6e553d34477f7edc90ac491d4606321.tar.lz
nixos_system-62ec6992a6e553d34477f7edc90ac491d4606321.tar.xz
nixos_system-62ec6992a6e553d34477f7edc90ac491d4606321.tar.zst
nixos_system-62ec6992a6e553d34477f7edc90ac491d4606321.zip
Connect obelix to mesh network
Diffstat (limited to 'host/obelix.nix')
-rw-r--r--host/obelix.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/host/obelix.nix b/host/obelix.nix
index 477819c..c922cea 100644
--- a/host/obelix.nix
+++ b/host/obelix.nix
@@ -30,4 +30,22 @@
};
services.xserver.videoDrivers = [ "nvidiaBeta" ];
+
+ networking.wireguard.interfaces = {
+ wg0 = {
+ ips = [ "10.100.0.2/24" ];
+
+ privateKeyFile = "/etc/wireguard/private";
+
+ peers = [
+ { # automatix
+ publicKey = "B0tkjq+5SfECKx1gWEP5JVWOIaRWL2JNE7iSpMmN4F0=";
+ allowedIPs = [ "10.100.0.0/24" ];
+ endpoint = "kummerlaender.eu:54321";
+
+ persistentKeepalive = 10;
+ }
+ ];
+ };
+ };
}