summaryrefslogtreecommitdiff
path: root/host/role/desktop.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2018-09-21 17:49:51 +0200
committerAdrian Kummerlaender2018-09-21 17:49:51 +0200
commit0024a2ca7918be83ad812b02348cb49dd2ff2d57 (patch)
tree53e12738aa868fa7025083fd90df9ff0d524d8e9 /host/role/desktop.nix
parent7de3c3bee50247cd3a1102a5eab0d8ebb9ca0432 (diff)
downloadnixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.tar
nixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.tar.gz
nixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.tar.bz2
nixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.tar.lz
nixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.tar.xz
nixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.tar.zst
nixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.zip
Add basic automatix config
Extract desktop-specific settings that are shared by asterix and obelix into desktop role.
Diffstat (limited to 'host/role/desktop.nix')
-rw-r--r--host/role/desktop.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/host/role/desktop.nix b/host/role/desktop.nix
new file mode 100644
index 0000000..cf20500
--- /dev/null
+++ b/host/role/desktop.nix
@@ -0,0 +1,45 @@
+{ pkgs, ... }:
+
+{
+ fileSystems."/".options = [ "noatime" "nodiratime" "discard" ];
+
+ sound.enable = true;
+ hardware = {
+ opengl.driSupport32Bit = true;
+ pulseaudio = {
+ enable = true;
+ support32Bit = true;
+ };
+ };
+
+ services = {
+ journald = {
+ extraConfig = ''Storage=volatile'';
+ };
+
+ openvpn.servers = {
+ KIT = {
+ config = import ./conf/vpn/kit.ovpn.nix;
+ autoStart = false;
+ };
+ };
+
+ xserver = {
+ enable = true;
+ layout = "de";
+ xkbOptions = "caps:escape";
+
+ displayManager.slim = {
+ enable = true;
+ autoLogin = true;
+ defaultUser = "common";
+ };
+
+ desktopManager.default = "none";
+ };
+ };
+
+ environment.systemPackages = with pkgs; [
+ hdparm ntfs3g
+ ];
+}