summaryrefslogtreecommitdiff
path: root/pkgs/vim/vim.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2018-04-20 13:31:10 +0200
committerAdrian Kummerlaender2018-04-20 13:31:10 +0200
commit478ce7035ab7af733a0390b242affb656539f16d (patch)
treeae3c2f22d724f430a7bd34446252250c122a7616 /pkgs/vim/vim.nix
downloadnixos_system-478ce7035ab7af733a0390b242affb656539f16d.tar
nixos_system-478ce7035ab7af733a0390b242affb656539f16d.tar.gz
nixos_system-478ce7035ab7af733a0390b242affb656539f16d.tar.bz2
nixos_system-478ce7035ab7af733a0390b242affb656539f16d.tar.lz
nixos_system-478ce7035ab7af733a0390b242affb656539f16d.tar.xz
nixos_system-478ce7035ab7af733a0390b242affb656539f16d.tar.zst
nixos_system-478ce7035ab7af733a0390b242affb656539f16d.zip
Start tracking system configuration
Diffstat (limited to 'pkgs/vim/vim.nix')
-rw-r--r--pkgs/vim/vim.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/pkgs/vim/vim.nix b/pkgs/vim/vim.nix
new file mode 100644
index 0000000..0af940e
--- /dev/null
+++ b/pkgs/vim/vim.nix
@@ -0,0 +1,14 @@
+{ pkgs, ... }:
+
+let
+ custom_vim = pkgs.vim_configurable.customize {
+ name = "vim";
+ vimrcConfig = (import ./custom.nix { pkgs = pkgs; });
+ };
+in pkgs.lib.overrideDerivation custom_vim ( o: {
+ gui = true;
+ ftNixSupport = true;
+ cscopeSupport = true;
+ fontsetSupport = true;
+ multibyteSupport = true;
+} )