summaryrefslogtreecommitdiff
path: root/conf/fish.nix
diff options
context:
space:
mode:
Diffstat (limited to 'conf/fish.nix')
-rw-r--r--conf/fish.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/conf/fish.nix b/conf/fish.nix
index 0ea7348..6a654f5 100644
--- a/conf/fish.nix
+++ b/conf/fish.nix
@@ -45,7 +45,11 @@
echo -n -s 'λ ' "$__fish_prompt_cwd" (prompt_pwd) "$__fish_prompt_normal"
if test $IN_NIX_SHELL
- echo -n -s ' (nix-shell)'
+ if test $NIX_SHELL_NAME
+ echo -n -s ' (' $NIX_SHELL_NAME ')'
+ else
+ echo -n -s ' (nix-shell)'
+ end
end
if test $last_status -gt 0