summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix55
1 files changed, 35 insertions, 20 deletions
diff --git a/configuration.nix b/configuration.nix
index 920bf70..538745d 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -1,29 +1,44 @@
-{ config, pkgs, ... }:
-
+{ config, pkgs, pkgs-personal, hostname, ... }:
{
- system.stateVersion = "18.09";
-
imports = [
- ./fish.nix
- ./host/current.nix
./user/common.nix
+ (./host + ("/" + hostname + ".nix"))
];
+ console.keyMap = "de";
+
i18n = {
- consoleKeyMap = "de";
defaultLocale = "en_US.UTF-8";
+ supportedLocales = [
+ "en_US.UTF-8/UTF-8"
+ "de_DE.UTF-8/UTF-8"
+ ];
};
time.timeZone = "Europe/Berlin";
nixpkgs.config.allowUnfree = true;
+ nix = {
+ package = pkgs.nixUnstable;
+
+ settings = {
+ allowed-users = [ "common" ];
+ trusted-users = [ "root" "common" ];
+ };
+
+ extraOptions = ''
+ experimental-features = nix-command flakes
+ '';
+ };
+
networking.nameservers = [
"1.1.1.1"
"2606:4700:4700::1111"
];
programs = {
+ fish.enable = true;
bash.enableCompletion = true;
gnupg.agent = {
enable = true;
@@ -33,22 +48,22 @@
services.openssh = {
enable = true;
- passwordAuthentication = false;
- permitRootLogin = "no";
+ settings = {
+ PasswordAuthentication = false;
+ PermitRootLogin = "no";
+ X11Forwarding = true;
+ };
};
environment = {
- systemPackages = let
- # use latest nvim
- nixpkgs-unstable = import <nixpkgs-unstable> { };
- mypkgs = import <mypkgs> { pkgs = nixpkgs-unstable; };
- in [
- pkgs.psmisc
- pkgs.htop
- pkgs.git
- pkgs.silver-searcher
- pkgs.renameutils
- mypkgs.custom-neovim
+ systemPackages = with pkgs; [
+ psmisc
+ htop
+ git
+ p7zip
+ silver-searcher
+ renameutils
+ pkgs-personal.custom-neovim
];
variables = {