summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix54
1 files changed, 33 insertions, 21 deletions
diff --git a/configuration.nix b/configuration.nix
index e9e20d6..538745d 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -1,28 +1,36 @@
-{ config, pkgs, ... }:
-
-let
- mypkgs = import <mypkgs> { };
-
-in {
- system.stateVersion = "18.09";
-
+{ config, pkgs, pkgs-personal, hostname, ... }:
+{
imports = [
- ./fish.nix
- ./host/current.nix
./user/common.nix
+ (./host + ("/" + hostname + ".nix"))
];
console.keyMap = "de";
i18n = {
defaultLocale = "en_US.UTF-8";
+ supportedLocales = [
+ "en_US.UTF-8/UTF-8"
+ "de_DE.UTF-8/UTF-8"
+ ];
};
time.timeZone = "Europe/Berlin";
nixpkgs.config.allowUnfree = true;
- nix.allowedUsers = [ "common" ];
+ nix = {
+ package = pkgs.nixUnstable;
+
+ settings = {
+ allowed-users = [ "common" ];
+ trusted-users = [ "root" "common" ];
+ };
+
+ extraOptions = ''
+ experimental-features = nix-command flakes
+ '';
+ };
networking.nameservers = [
"1.1.1.1"
@@ -30,6 +38,7 @@ in {
];
programs = {
+ fish.enable = true;
bash.enableCompletion = true;
gnupg.agent = {
enable = true;
@@ -39,19 +48,22 @@ in {
services.openssh = {
enable = true;
- passwordAuthentication = false;
- permitRootLogin = "no";
- forwardX11 = true;
+ settings = {
+ PasswordAuthentication = false;
+ PermitRootLogin = "no";
+ X11Forwarding = true;
+ };
};
environment = {
- systemPackages = [
- pkgs.psmisc
- pkgs.htop
- pkgs.git
- pkgs.silver-searcher
- pkgs.renameutils
- mypkgs.custom-neovim
+ systemPackages = with pkgs; [
+ psmisc
+ htop
+ git
+ p7zip
+ silver-searcher
+ renameutils
+ pkgs-personal.custom-neovim
];
variables = {