summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/configuration.nix b/configuration.nix
index 5da9f94..538745d 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -38,6 +38,7 @@
];
programs = {
+ fish.enable = true;
bash.enableCompletion = true;
gnupg.agent = {
enable = true;
@@ -47,9 +48,11 @@
services.openssh = {
enable = true;
- passwordAuthentication = false;
- permitRootLogin = "no";
- forwardX11 = true;
+ settings = {
+ PasswordAuthentication = false;
+ PermitRootLogin = "no";
+ X11Forwarding = true;
+ };
};
environment = {