summaryrefslogtreecommitdiff
path: root/host/athena.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/athena.nix')
-rw-r--r--host/athena.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/host/athena.nix b/host/athena.nix
index cc9c80d..c37318f 100644
--- a/host/athena.nix
+++ b/host/athena.nix
@@ -28,6 +28,24 @@
users.extraUsers.common.extraGroups = [ "networkmanager" "libvirtd" ];
+ networking.wireguard.interfaces = {
+ wg0 = {
+ ips = [ "10.100.0.4/24" ];
+
+ privateKeyFile = "/etc/wireguard/private";
+
+ peers = [
+ { # automatix
+ publicKey = "B0tkjq+5SfECKx1gWEP5JVWOIaRWL2JNE7iSpMmN4F0=";
+ allowedIPs = [ "10.100.0.0/24" ];
+ endpoint = "kummerlaender.eu:54321";
+
+ persistentKeepalive = 10;
+ }
+ ];
+ };
+ };
+
services = {
upower.enable = true;
acpid.enable = true;
@@ -55,6 +73,8 @@
hardware.bluetooth.enable = true;
+ hardware.opengl.extraPackages = [ pkgs.intel-ocl ];
+
services.tlp = {
enable = true;
extraConfig = ''