summaryrefslogtreecommitdiff
path: root/host/automatix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/automatix.nix')
-rw-r--r--host/automatix.nix28
1 files changed, 26 insertions, 2 deletions
diff --git a/host/automatix.nix b/host/automatix.nix
index f19de69..7c6edd0 100644
--- a/host/automatix.nix
+++ b/host/automatix.nix
@@ -12,10 +12,11 @@
boot.loader.grub = {
enable = true;
- version = 2;
device = "/dev/sda";
};
+ nix.settings.allowed-users = [ "public" ];
+
networking = {
hostName = "automatix";
@@ -54,8 +55,31 @@
};
};
+ systemd.timers."generate-ical-of-org-agenda" = {
+ enable = true;
+ wantedBy = [ "timers.target" ];
+ timerConfig = {
+ OnCalendar = "daily";
+ Persistent = true;
+ Unit = "generate-ical-of-org-agenda.service";
+ };
+ };
+
+ systemd.services."generate-ical-of-org-agenda" = {
+ enable = true;
+ script = "${pkgs.emacs-nox}/bin/emacs -batch -l /var/lib/syncthing/org-cal-export.el";
+ serviceConfig = {
+ Type = "oneshot";
+ User = "syncthing";
+ };
+ };
+
+ users.users.syncthing.shell = pkgs.bash;
+
security.acme = {
acceptTerms = true;
- email = "key@kummerlaender.eu";
+ defaults.email = "key@kummerlaender.eu";
};
+
+ system.stateVersion = "18.09";
}