summaryrefslogtreecommitdiff
path: root/host/hardware/athena.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/hardware/athena.nix')
-rw-r--r--host/hardware/athena.nix11
1 files changed, 5 insertions, 6 deletions
diff --git a/host/hardware/athena.nix b/host/hardware/athena.nix
index 4849b6f..508507a 100644
--- a/host/hardware/athena.nix
+++ b/host/hardware/athena.nix
@@ -8,26 +8,25 @@
[ (modulesPath + "/installer/scan/not-detected.nix")
];
- boot.initrd.availableKernelModules = [ "xhci_pci" "nvme" "usb_storage" "sd_mod" ];
+ boot.initrd.availableKernelModules = [ "xhci_pci" "thunderbolt" "nvme" "usb_storage" "sd_mod" "sdhci_pci" ];
boot.initrd.kernelModules = [ "dm-snapshot" ];
boot.kernelModules = [ "kvm-intel" "fuse" ];
boot.extraModulePackages = [ ];
fileSystems."/" =
- { device = "/dev/disk/by-uuid/198fbcc1-0b72-4465-891a-5959c6bfcfc6";
+ { device = "/dev/disk/by-uuid/3af135f5-9bfe-4ab4-abb3-2e93caad08ea";
fsType = "ext4";
};
fileSystems."/boot" =
- { device = "/dev/disk/by-uuid/6510-C4DF";
+ { device = "/dev/disk/by-uuid/6290-9BB5";
fsType = "vfat";
};
swapDevices =
- [ { device = "/dev/disk/by-uuid/60bd356a-c28e-4f5e-90ff-6331a3cb7252"; }
+ [ { device = "/dev/disk/by-uuid/b3845af4-030a-4bba-bad8-89c548bde40f"; }
];
powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
- # high-resolution display
- hardware.video.hidpi.enable = lib.mkDefault true;
+ hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
}