summaryrefslogtreecommitdiff
path: root/host/hardware/hephaestus.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/hardware/hephaestus.nix')
-rw-r--r--host/hardware/hephaestus.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/host/hardware/hephaestus.nix b/host/hardware/hephaestus.nix
new file mode 100644
index 0000000..69a69cf
--- /dev/null
+++ b/host/hardware/hephaestus.nix
@@ -0,0 +1,30 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "ahci" "usbhid" "usb_storage" "sd_mod" ];
+ boot.initrd.kernelModules = [ "dm-snapshot" ];
+ boot.kernelModules = [ "kvm-amd" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/4137e9a6-a4cd-4758-a9db-ae684d17e4de";
+ fsType = "ext4";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/0CF7-ED16";
+ fsType = "vfat";
+ };
+
+ swapDevices =
+ [ { device = "/dev/disk/by-uuid/b4d536f0-9b83-44a8-84f3-f44c1deee870"; }
+ ];
+
+}