summaryrefslogtreecommitdiff
path: root/host/hardware/obelix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/hardware/obelix.nix')
-rw-r--r--host/hardware/obelix.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/host/hardware/obelix.nix b/host/hardware/obelix.nix
new file mode 100644
index 0000000..769981a
--- /dev/null
+++ b/host/hardware/obelix.nix
@@ -0,0 +1,31 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, ... }:
+
+{
+ imports =
+ [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+ ];
+
+ boot.initrd.availableKernelModules = [ "xhci_pci" "ehci_pci" "ahci" "sd_mod" "sr_mod" ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/ac766046-c9cd-4771-b591-f74d50aa8500";
+ fsType = "ext4";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/20ea14b0-33ef-4fa1-a861-fd1156a0b60d";
+ fsType = "ext2";
+ };
+
+ swapDevices =
+ [ { device = "/dev/disk/by-uuid/0732dc69-7d30-4e99-af6d-d12b927945eb"; }
+ ];
+
+ nix.maxJobs = lib.mkDefault 8;
+ powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
+}