summaryrefslogtreecommitdiff
path: root/host/majestix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/majestix.nix')
-rw-r--r--host/majestix.nix37
1 files changed, 15 insertions, 22 deletions
diff --git a/host/majestix.nix b/host/majestix.nix
index da855d6..3d33aca 100644
--- a/host/majestix.nix
+++ b/host/majestix.nix
@@ -7,17 +7,18 @@
];
boot = {
- loader.grub = {
- enable = true;
- version = 2;
- device = "/dev/sda";
+ loader = {
+ systemd-boot.enable = true;
+ efi.canTouchEfiVariables = true;
};
- initrd.luks.devices = [ {
- name = "encrypted";
- device = "/dev/sda2";
- preLVM = true;
- } ];
+ initrd.luks.devices = {
+ encrypted = {
+ device = "/dev/nvme0n1p2";
+ preLVM = true;
+ allowDiscards = true;
+ };
+ };
};
networking = {
@@ -32,22 +33,10 @@
acpid.enable = true;
xserver = {
- videoDrivers = [ "intel" ];
- };
-
- printing = {
- enable = true;
- drivers = [ pkgs.brgenml1cupswrapper ];
- };
-
- avahi = {
- enable = true;
- nssmdns = true;
+ videoDrivers = [ "nvidia" ];
};
};
- hardware.opengl.extraPackages = [ pkgs.intel-ocl ];
-
networking.wireguard.interfaces = {
wg0 = {
ips = [ "10.100.0.3/24" ];
@@ -64,4 +53,8 @@
];
};
};
+
+ nix.maxJobs = 32;
+
+ system.stateVersion = "20.09";
}