summaryrefslogtreecommitdiff
path: root/host/obelix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/obelix.nix')
-rw-r--r--host/obelix.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/host/obelix.nix b/host/obelix.nix
index c20dbab..f260768 100644
--- a/host/obelix.nix
+++ b/host/obelix.nix
@@ -1,3 +1,5 @@
+{ pkgs, ... }:
+
{
imports = [ ./hardware/obelix.nix ];
@@ -18,6 +20,16 @@
} ];
};
+ systemd.services.spin-down-storage = {
+ enable = true;
+ description = "Spin down storage drive by default";
+ serviceConfig = {
+ Type = "oneshot";
+ ExecStart = "${pkgs.hdparm}/bin/hdparm -q -S 120 -y /dev/disk/by-label/storage";
+ };
+ wantedBy = [ "multi-user.target" ];
+ };
+
networking = {
hostName = "obelix";
firewall.enable = false;