summaryrefslogtreecommitdiff
path: root/host/obelix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/obelix.nix')
-rw-r--r--host/obelix.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/host/obelix.nix b/host/obelix.nix
new file mode 100644
index 0000000..c20dbab
--- /dev/null
+++ b/host/obelix.nix
@@ -0,0 +1,27 @@
+{
+ imports = [ ./hardware/obelix.nix ];
+
+ boot = {
+ kernelParams = [ "vga=0x31B" ];
+
+ loader.grub = {
+ enable = true;
+ version = 2;
+ device = "/dev/sdb";
+ };
+
+ initrd.luks.devices = [ {
+ name = "root";
+ device = "/dev/disk/by-uuid/6205da24-b1b2-402c-b175-4036e678dea9";
+ preLVM = true;
+ allowDiscards = true;
+ } ];
+ };
+
+ networking = {
+ hostName = "obelix";
+ firewall.enable = false;
+ };
+
+ services.xserver.videoDrivers = [ "nvidiaBeta" ];
+}