summaryrefslogtreecommitdiff
path: root/host/obelix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/obelix.nix')
-rw-r--r--host/obelix.nix15
1 files changed, 8 insertions, 7 deletions
diff --git a/host/obelix.nix b/host/obelix.nix
index c922cea..583fbde 100644
--- a/host/obelix.nix
+++ b/host/obelix.nix
@@ -10,18 +10,19 @@
loader.grub = {
enable = true;
version = 2;
- device = "/dev/sdb";
+ device = "/dev/sda";
extraConfig = ''
set gfxpayload=1920x1200x32
'';
};
- initrd.luks.devices = [ {
- name = "root";
- device = "/dev/disk/by-uuid/6205da24-b1b2-402c-b175-4036e678dea9";
- preLVM = true;
- allowDiscards = true;
- } ];
+ initrd.luks.devices = {
+ root = {
+ device = "/dev/disk/by-uuid/6205da24-b1b2-402c-b175-4036e678dea9";
+ preLVM = true;
+ allowDiscards = true;
+ };
+ };
};
networking = {