summaryrefslogtreecommitdiff
path: root/host/software/desktop/kit.vpn.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/software/desktop/kit.vpn.nix')
-rw-r--r--host/software/desktop/kit.vpn.nix24
1 files changed, 6 insertions, 18 deletions
diff --git a/host/software/desktop/kit.vpn.nix b/host/software/desktop/kit.vpn.nix
index 726356d..9f51a42 100644
--- a/host/software/desktop/kit.vpn.nix
+++ b/host/software/desktop/kit.vpn.nix
@@ -3,25 +3,13 @@
{
services.openvpn.servers = {
KIT = {
- # adapted from https://www.scc.kit.edu/scc/net/openvpn/os/debian/kit.ovpn
- config = ''
- client
- remote 141.52.8.20
- port 1194
- dev tun
- proto udp
- auth-user-pass
- nobind
- comp-lzo no
- tls-version-min 1.2
- ca ${./asset/T-TeleSec_GlobalRoot_Class_2.pem}
- verify-x509-name "C=DE, ST=Baden-Wuerttemberg, L=Karlsruhe, O=Karlsruhe Institute of Technology, OU=Steinbuch Centre for Computing, CN=ovpn.scc.kit.edu" subject
- cipher AES-256-CBC
- auth SHA384
- verb 3
- script-security 2
- '';
autoStart = false;
+ config = let
+ path = pkgs.fetchurl {
+ url = "https://www.scc.kit.edu/scc/net/openvpn/conf/kit-split.ovpn";
+ hash = "sha256-j4pCKyU7t1ZmwIGm5kuUgZ26Qiqa1jzoDZcP2x+A9pM=";
+ };
+ in "config ${path}";
};
};
}