summaryrefslogtreecommitdiff
path: root/host/software/desktop/teensy.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/software/desktop/teensy.nix')
-rw-r--r--host/software/desktop/teensy.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/host/software/desktop/teensy.nix b/host/software/desktop/teensy.nix
new file mode 100644
index 0000000..461ad27
--- /dev/null
+++ b/host/software/desktop/teensy.nix
@@ -0,0 +1,11 @@
+{ pkgs, ... }:
+
+{
+ services.udev.extraRules = ''
+ # UDEV rules for Teensy USB
+ ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", ENV{ID_MM_DEVICE_IGNORE}="1"
+ ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789A]?", ENV{MTP_NO_PROBE}="1"
+ SUBSYSTEMS=="usb", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789ABCD]?", MODE:="0666"
+ KERNEL=="ttyACM*", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", MODE:="0666"
+ '';
+}