summaryrefslogtreecommitdiff
path: root/host/software/pkgs/vim/custom.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/software/pkgs/vim/custom.nix')
-rw-r--r--host/software/pkgs/vim/custom.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/host/software/pkgs/vim/custom.nix b/host/software/pkgs/vim/custom.nix
new file mode 100644
index 0000000..4719b72
--- /dev/null
+++ b/host/software/pkgs/vim/custom.nix
@@ -0,0 +1,42 @@
+{ pkgs }:
+
+let
+ vimrc = builtins.readFile ./asset/rc.vim;
+ plugins = pkgs.callPackage ./plugins.nix {};
+in
+{
+ vam = {
+ knownPlugins = pkgs.vimPlugins // plugins;
+ pluginDictionaries = [
+ { names = [
+ # UI enhancements
+ "vim-airline"
+ "goyo"
+ "vim-toggle-ui-elements"
+ # load project specific config
+ "vim-localvimrc"
+ # colors, syntax highlighting
+ "vim-color-akr"
+ "vim-polyglot"
+ "vim-addon-nix"
+ # file, buffer management
+ "ctrlp"
+ "vim-counterpoint"
+ "vim-signature"
+ # undo history tree
+ "vim-mundo"
+ # editing enhancements
+ "vim-wordmotion"
+ "vim-autoformat"
+ "surround"
+ "vim-unimpaired"
+ "vim-far"
+ # git integration
+ "fugitive"
+ "vim-gitgutter"
+ "vim-gina"
+ ];}
+ ];
+ };
+ customRC = vimrc;
+}