summaryrefslogtreecommitdiff
path: root/pkgs/vim/custom.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/vim/custom.nix')
-rw-r--r--pkgs/vim/custom.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/vim/custom.nix b/pkgs/vim/custom.nix
new file mode 100644
index 0000000..32700f6
--- /dev/null
+++ b/pkgs/vim/custom.nix
@@ -0,0 +1,26 @@
+{ pkgs }:
+
+let
+ vimrc = builtins.readFile ./conf/rc.vim;
+ plugins = pkgs.callPackage ./plugins.nix {};
+in
+{
+ vam = {
+ knownPlugins = pkgs.vimPlugins // plugins;
+ pluginDictionaries = [
+ { names = [
+ "ctrlp"
+ "undotree"
+ "vim-gitgutter"
+ "goyo"
+ "vim-localvimrc"
+ "tagbar"
+ "vim-addon-nix"
+ "vim-autoformat"
+ "vim-csexact"
+ "vim-color-akr"
+ ];}
+ ];
+ };
+ customRC = vimrc;
+}