summaryrefslogtreecommitdiff
path: root/pkgs/vim/custom.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/vim/custom.nix')
-rw-r--r--pkgs/vim/custom.nix35
1 files changed, 21 insertions, 14 deletions
diff --git a/pkgs/vim/custom.nix b/pkgs/vim/custom.nix
index 7a7d9ed..f0150d2 100644
--- a/pkgs/vim/custom.nix
+++ b/pkgs/vim/custom.nix
@@ -9,25 +9,32 @@ in
knownPlugins = pkgs.vimPlugins // plugins;
pluginDictionaries = [
{ names = [
- "ctrlp"
- "goyo"
- "vim-far"
- "fugitive"
- "surround"
- "vim-unimpaired"
- "vim-mundo"
+ # UI enhancements
"vim-airline"
- "vim-gitgutter"
- "vim-git-commit-viewer"
- "vim-signature"
+ "goyo"
+ "vim-toggle-ui-elements"
+ # load project specific config
"vim-localvimrc"
- "vim-addon-nix"
- "vim-autoformat"
+ # colors, syntax highlighting
+ "vim-color-akr"
"vim-polyglot"
+ "vim-addon-nix"
+ # file, buffer management
+ "ctrlp"
"vim-counterpoint"
- "vim-toggle-ui-elements"
+ "vim-signature"
+ # undo history tree
+ "vim-mundo"
+ # editing enhancements
"vim-wordmotion"
- "vim-color-akr"
+ "vim-autoformat"
+ "surround"
+ "vim-unimpaired"
+ "vim-far"
+ # git integration
+ "fugitive"
+ "vim-gitgutter"
+ "vim-gina"
];}
];
};