summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Kummerlaender2020-03-22 21:22:10 +0100
committerAdrian Kummerlaender2020-03-22 21:22:10 +0100
commit7aacf581bc43da8633989f553f38b1689d5a7724 (patch)
tree5621d2c601486f7ce7a6fa3a38b2c8cc12dd716c
parent13f21f316aa6b9a5a2df914ef0a839215a05a195 (diff)
downloadpkgs-7aacf581bc43da8633989f553f38b1689d5a7724.tar
pkgs-7aacf581bc43da8633989f553f38b1689d5a7724.tar.gz
pkgs-7aacf581bc43da8633989f553f38b1689d5a7724.tar.bz2
pkgs-7aacf581bc43da8633989f553f38b1689d5a7724.tar.lz
pkgs-7aacf581bc43da8633989f553f38b1689d5a7724.tar.xz
pkgs-7aacf581bc43da8633989f553f38b1689d5a7724.tar.zst
pkgs-7aacf581bc43da8633989f553f38b1689d5a7724.zip
Use writeShellScriptBin trivial builder for nix-shell wrapper
Thanks to @jobojeha for the suggestion
-rw-r--r--pkgs/persistent-nix-shell/default.nix10
1 files changed, 3 insertions, 7 deletions
diff --git a/pkgs/persistent-nix-shell/default.nix b/pkgs/persistent-nix-shell/default.nix
index 5e53ee6..906fc2d 100644
--- a/pkgs/persistent-nix-shell/default.nix
+++ b/pkgs/persistent-nix-shell/default.nix
@@ -1,9 +1,5 @@
{ stdenv, pkgs, ... }:
-pkgs.writeTextFile {
- name = "persistent-nix-shell";
- executable = true;
- destination = "/bin/persistent-nix-shell";
-
- text = builtins.readFile ./persistent-nix-shell.sh;
-}
+pkgs.writeShellScriptBin
+ "persistent-nix-shell"
+ (builtins.readFile ./persistent-nix-shell.sh)