summaryrefslogtreecommitdiff
path: root/pkgs/custom-neovim/plugins.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2019-03-05 16:21:47 +0100
committerAdrian Kummerlaender2019-03-05 16:21:47 +0100
commitb6544120a820700785ef0d05b462df2e4bb17c53 (patch)
treef3942485f4771b28eabcc4d94ef214d0047b0f89 /pkgs/custom-neovim/plugins.nix
parent39e5cba8ad350c1ecee66ee18093f20146a60bba (diff)
downloadpkgs-b6544120a820700785ef0d05b462df2e4bb17c53.tar
pkgs-b6544120a820700785ef0d05b462df2e4bb17c53.tar.gz
pkgs-b6544120a820700785ef0d05b462df2e4bb17c53.tar.bz2
pkgs-b6544120a820700785ef0d05b462df2e4bb17c53.tar.lz
pkgs-b6544120a820700785ef0d05b462df2e4bb17c53.tar.xz
pkgs-b6544120a820700785ef0d05b462df2e4bb17c53.tar.zst
pkgs-b6544120a820700785ef0d05b462df2e4bb17c53.zip
Test simpler setup using vim-lsp
Feels less distracting and faster. I don't actually want to turn this vim setup into a always active intellisense-like experience but rather have code introspection quickly available if I actually need it.
Diffstat (limited to 'pkgs/custom-neovim/plugins.nix')
-rw-r--r--pkgs/custom-neovim/plugins.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/pkgs/custom-neovim/plugins.nix b/pkgs/custom-neovim/plugins.nix
index 9ff92f2..5e0f6ea 100644
--- a/pkgs/custom-neovim/plugins.nix
+++ b/pkgs/custom-neovim/plugins.nix
@@ -76,6 +76,24 @@ in {
};
};
+ vim-lsp = buildVimPlugin {
+ name = "vim-lsp";
+ src = fetchgit {
+ url = "https://github.com/prabirshrestha/vim-lsp.git";
+ rev = "0310241af11adc6c3a7ba93955bc27b15744c957";
+ sha256 = "0ccd6is75qlk8mg9wpwp1ypq68p7lgbq1c1jbpr6pwr59s53r4lx";
+ };
+ };
+
+ async = buildVimPlugin {
+ name = "async";
+ src = fetchgit {
+ url = "https://github.com/prabirshrestha/async.vim.git";
+ rev = "f3014550d7a799097e56b094104dd2cd66cf2612";
+ sha256 = "0zn25qwycynagrij5rsp1x7kbfz612gn7xda0hvm4y7qr3pal77p";
+ };
+ };
+
vim-color-akr = buildVimPlugin {
name = "vim-color-akr";
src = ./asset/vim-color-akr;