summaryrefslogtreecommitdiff
path: root/pkgs/custom-vim/custom.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2018-09-23 20:14:29 +0200
committerAdrian Kummerlaender2018-09-23 20:14:47 +0200
commit43bc484b4e3dc47512872e62779d7fe98fac93a1 (patch)
tree2a05d9e872a8e0508e0b27b3fd62aefac5fa3a1a /pkgs/custom-vim/custom.nix
downloadpkgs-43bc484b4e3dc47512872e62779d7fe98fac93a1.tar
pkgs-43bc484b4e3dc47512872e62779d7fe98fac93a1.tar.gz
pkgs-43bc484b4e3dc47512872e62779d7fe98fac93a1.tar.bz2
pkgs-43bc484b4e3dc47512872e62779d7fe98fac93a1.tar.lz
pkgs-43bc484b4e3dc47512872e62779d7fe98fac93a1.tar.xz
pkgs-43bc484b4e3dc47512872e62779d7fe98fac93a1.tar.zst
pkgs-43bc484b4e3dc47512872e62779d7fe98fac93a1.zip
Initial import of my custom Nix derivations
Diffstat (limited to 'pkgs/custom-vim/custom.nix')
-rw-r--r--pkgs/custom-vim/custom.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/pkgs/custom-vim/custom.nix b/pkgs/custom-vim/custom.nix
new file mode 100644
index 0000000..4719b72
--- /dev/null
+++ b/pkgs/custom-vim/custom.nix
@@ -0,0 +1,42 @@
+{ pkgs }:
+
+let
+ vimrc = builtins.readFile ./asset/rc.vim;
+ plugins = pkgs.callPackage ./plugins.nix {};
+in
+{
+ vam = {
+ knownPlugins = pkgs.vimPlugins // plugins;
+ pluginDictionaries = [
+ { names = [
+ # UI enhancements
+ "vim-airline"
+ "goyo"
+ "vim-toggle-ui-elements"
+ # load project specific config
+ "vim-localvimrc"
+ # colors, syntax highlighting
+ "vim-color-akr"
+ "vim-polyglot"
+ "vim-addon-nix"
+ # file, buffer management
+ "ctrlp"
+ "vim-counterpoint"
+ "vim-signature"
+ # undo history tree
+ "vim-mundo"
+ # editing enhancements
+ "vim-wordmotion"
+ "vim-autoformat"
+ "surround"
+ "vim-unimpaired"
+ "vim-far"
+ # git integration
+ "fugitive"
+ "vim-gitgutter"
+ "vim-gina"
+ ];}
+ ];
+ };
+ customRC = vimrc;
+}