summaryrefslogtreecommitdiff
path: root/pkgs/xslt/input-xslt/default.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2021-08-19 12:07:33 +0200
committerAdrian Kummerlaender2021-08-19 12:07:33 +0200
commit5e27bc6838920fe2948bc0953a519232bced0397 (patch)
tree25881a90f87f1f0e5a28bee4cf5907838aa42140 /pkgs/xslt/input-xslt/default.nix
parent122a6169f67f2b996b529ef2be6c4dbd74d4b166 (diff)
downloadpkgs-5e27bc6838920fe2948bc0953a519232bced0397.tar
pkgs-5e27bc6838920fe2948bc0953a519232bced0397.tar.gz
pkgs-5e27bc6838920fe2948bc0953a519232bced0397.tar.bz2
pkgs-5e27bc6838920fe2948bc0953a519232bced0397.tar.lz
pkgs-5e27bc6838920fe2948bc0953a519232bced0397.tar.xz
pkgs-5e27bc6838920fe2948bc0953a519232bced0397.tar.zst
pkgs-5e27bc6838920fe2948bc0953a519232bced0397.zip
Flake-ify
Diffstat (limited to 'pkgs/xslt/input-xslt/default.nix')
-rw-r--r--pkgs/xslt/input-xslt/default.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/pkgs/xslt/input-xslt/default.nix b/pkgs/xslt/input-xslt/default.nix
index 50ba070..b06e4af 100644
--- a/pkgs/xslt/input-xslt/default.nix
+++ b/pkgs/xslt/input-xslt/default.nix
@@ -1,20 +1,20 @@
-{ stdenv, fetchFromGitHub, cmake, boost, xalanc, xercesc, discount }:
+{ pkgs, ... }:
-stdenv.mkDerivation rec {
+pkgs.stdenv.mkDerivation rec {
name = "input-xslt";
- src = fetchFromGitHub {
+ src = pkgs.fetchFromGitHub {
owner = "KnairdA";
repo = "InputXSLT";
rev = "master";
sha256 = "1p2y1m65h1k3g0nj8sgc05f9w880wngrd2n1b53dhhqq4scsj2a7";
};
- buildInputs = [ cmake boost xalanc xercesc discount ];
+ buildInputs = with pkgs; [ cmake boost xalanc xercesc discount ];
- meta = with stdenv.lib; {
+ meta = with pkgs.stdenv.lib; {
description = "InputXSLT";
homepage = https://github.com/KnairdA/InputXSLT/;
- license = stdenv.lib.licenses.asl20;
+ license = pkgs.stdenv.lib.licenses.asl20;
};
}