summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix5
1 files changed, 1 insertions, 4 deletions
diff --git a/default.nix b/default.nix
index ff1439b..1552309 100644
--- a/default.nix
+++ b/default.nix
@@ -1,12 +1,9 @@
-{ system ? builtins.currentSystem }:
+{ system ? builtins.currentSystem, pkgs ? import <nixpkgs> { inherit system; }, ... }:
let
- pkgs = import <nixpkgs> { inherit system; };
-
callPackage = pkgs.lib.callPackageWith (pkgs // custom);
custom = {
- custom-vim = callPackage ./pkgs/custom-vim { };
custom-neovim = callPackage ./pkgs/custom-neovim { };
oomox-gtk-theme = t : callPackage ./pkgs/oomox-gtk-theme { theme = t; };