summaryrefslogtreecommitdiff
path: root/pkgs/xslt
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/xslt')
-rw-r--r--pkgs/xslt/BuildXSLT/default.nix23
-rw-r--r--pkgs/xslt/InputXSLT/default.nix20
-rw-r--r--pkgs/xslt/StaticXSLT/default.nix23
-rw-r--r--pkgs/xslt/makeweb/default.nix12
4 files changed, 78 insertions, 0 deletions
diff --git a/pkgs/xslt/BuildXSLT/default.nix b/pkgs/xslt/BuildXSLT/default.nix
new file mode 100644
index 0000000..4e5dcb6
--- /dev/null
+++ b/pkgs/xslt/BuildXSLT/default.nix
@@ -0,0 +1,23 @@
+{ stdenv, fetchFromGitHub }:
+
+stdenv.mkDerivation rec {
+ name = "BuildXSLT";
+
+ src = fetchFromGitHub {
+ owner = "KnairdA";
+ repo = "BuildXSLT";
+ rev = "master";
+ sha256 = "09kxhvhzn0r62l39zgj1kc21rb565fnc1y3sg48p4gi4v15xjmc6";
+ };
+
+ installPhase = ''
+ mkdir $out
+ cp -r * $out/
+ '';
+
+ meta = with stdenv.lib; {
+ description = "BuildXSLT";
+ homepage = https://github.com/KnairdA/BuildXSLT/;
+ license = stdenv.lib.licenses.mit;
+ };
+}
diff --git a/pkgs/xslt/InputXSLT/default.nix b/pkgs/xslt/InputXSLT/default.nix
new file mode 100644
index 0000000..a85bc37
--- /dev/null
+++ b/pkgs/xslt/InputXSLT/default.nix
@@ -0,0 +1,20 @@
+{ stdenv, fetchFromGitHub, cmake, boost, xalanc, xercesc, discount }:
+
+stdenv.mkDerivation rec {
+ name = "InputXSLT";
+
+ src = fetchFromGitHub {
+ owner = "KnairdA";
+ repo = "InputXSLT";
+ rev = "master";
+ sha256 = "1j9fld3sh1jyscnsx6ab9jn5x6q67rjh9p3bgsh5na1qrs40dql0";
+ };
+
+ buildInputs = [ cmake boost xalanc xercesc discount ];
+
+ meta = with stdenv.lib; {
+ description = "InputXSLT";
+ homepage = https://github.com/KnairdA/InputXSLT/;
+ license = stdenv.lib.licenses.asl20;
+ };
+}
diff --git a/pkgs/xslt/StaticXSLT/default.nix b/pkgs/xslt/StaticXSLT/default.nix
new file mode 100644
index 0000000..3caee06
--- /dev/null
+++ b/pkgs/xslt/StaticXSLT/default.nix
@@ -0,0 +1,23 @@
+{ stdenv, fetchFromGitHub }:
+
+stdenv.mkDerivation rec {
+ name = "StaticXSLT";
+
+ src = fetchFromGitHub {
+ owner = "KnairdA";
+ repo = "StaticXSLT";
+ rev = "master";
+ sha256 = "17gd181cw9yyc4h1fn7fikcgm8g7fdwm7d7fxwib4aynm18kwqad";
+ };
+
+ installPhase = ''
+ mkdir $out
+ cp -r * $out/
+ '';
+
+ meta = with stdenv.lib; {
+ description = "StaticXSLT";
+ homepage = https://github.com/KnairdA/StaticXSLT/;
+ license = stdenv.lib.licenses.mit;
+ };
+}
diff --git a/pkgs/xslt/makeweb/default.nix b/pkgs/xslt/makeweb/default.nix
new file mode 100644
index 0000000..0527bbc
--- /dev/null
+++ b/pkgs/xslt/makeweb/default.nix
@@ -0,0 +1,12 @@
+{ pkgs, ... }:
+
+let
+ InputXSLT = pkgs.callPackage ../InputXSLT { };
+ StaticXSLT = pkgs.callPackage ../StaticXSLT { };
+ BuildXSLT = pkgs.callPackage ../BuildXSLT { };
+in pkgs.writeScriptBin
+ "makeweb"
+ ''
+ #!/bin/sh
+ ${InputXSLT}/bin/ixslt --input make.xml --transformation ${BuildXSLT}/build.xsl --include ${StaticXSLT}/
+ ''