summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2021-10-09 23:41:40 +0200
committerAdrian Kummerlaender2021-10-09 23:41:40 +0200
commitb006b3c355616c89d66084880b5a5a87f0241009 (patch)
treec4a35025ff183154d8ef3d6c63535b82d605c25d /flake.nix
downloadteensy-env-b006b3c355616c89d66084880b5a5a87f0241009.tar
teensy-env-b006b3c355616c89d66084880b5a5a87f0241009.tar.gz
teensy-env-b006b3c355616c89d66084880b5a5a87f0241009.tar.bz2
teensy-env-b006b3c355616c89d66084880b5a5a87f0241009.tar.lz
teensy-env-b006b3c355616c89d66084880b5a5a87f0241009.tar.xz
teensy-env-b006b3c355616c89d66084880b5a5a87f0241009.tar.zst
teensy-env-b006b3c355616c89d66084880b5a5a87f0241009.zip
Basic build environment for Teensy 4.0 programs
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..03109f4
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,19 @@
+{
+ description = "Build environment for Teensy 4.0";
+
+ inputs = {
+ nixpkgs.url = github:NixOS/nixpkgs/nixos-21.05;
+ };
+
+ outputs = { self, nixpkgs, ... }: let
+ system = "x86_64-linux";
+ pkgs = import nixpkgs { inherit system; };
+
+ teensy-core = import ./core.nix { inherit pkgs; };
+ teensy-test = import ./test.nix { inherit pkgs teensy-core; };
+ in {
+ packages.${system} = {
+ inherit teensy-core teensy-test;
+ };
+ };
+}