summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix13
1 files changed, 11 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 560b5fa..43e8824 100644
--- a/flake.nix
+++ b/flake.nix
@@ -10,8 +10,17 @@
pkgs = import nixpkgs { inherit system; };
teensy-core = import ./core.nix { inherit pkgs; };
- teensy-test = import ./test.nix { inherit pkgs teensy-core; };
- teensy-ulisp = import ./ulisp.nix { inherit pkgs teensy-core; };
+
+ image = import ./build.nix { inherit pkgs teensy-core; };
+
+ teensy-test = image.build "teensy-test" ./test;
+
+ teensy-ulisp = let
+ ulisp-source = import ./ulisp.nix { inherit pkgs; };
+ in image.build
+ "teensy-ulisp"
+ (pkgs.linkFarmFromDrvs "ulisp" [ ulisp-source ]);
+
in {
packages.${system} = {
inherit teensy-core teensy-test teensy-ulisp;