aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerlaender2016-05-20 23:53:22 +0200
committerAdrian Kummerlaender2016-05-20 23:53:22 +0200
commitfefb5de652f3f07eda7bfb79ebb0134b64e5bd19 (patch)
treea5271847547d68b4265047d3ff9e9c0e367d6217 /CMakeLists.txt
parentd87a9b0960ddd4397325fe7240b484ec9f79e7af (diff)
downloadvoronoi-fefb5de652f3f07eda7bfb79ebb0134b64e5bd19.tar
voronoi-fefb5de652f3f07eda7bfb79ebb0134b64e5bd19.tar.gz
voronoi-fefb5de652f3f07eda7bfb79ebb0134b64e5bd19.tar.bz2
voronoi-fefb5de652f3f07eda7bfb79ebb0134b64e5bd19.tar.lz
voronoi-fefb5de652f3f07eda7bfb79ebb0134b64e5bd19.tar.xz
voronoi-fefb5de652f3f07eda7bfb79ebb0134b64e5bd19.tar.zst
voronoi-fefb5de652f3f07eda7bfb79ebb0134b64e5bd19.zip
Implement unit circle example
`unit_circle.sh` generates a animated GIF of the circle states between p=1 and p=3.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ccbfde7..6aeef3a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,8 +17,20 @@ add_executable(
src/ppm_pixel_stream.cc
)
+add_executable(
+ unit_circle
+ unit_circle.cc
+ src/imgen.cc
+ src/ppm_pixel_stream.cc
+)
+
target_link_libraries(
example
m
pthread
)
+
+target_link_libraries(
+ unit_circle
+ m
+)