aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerlaender2017-10-06 14:26:44 +0200
committerAdrian Kummerlaender2017-10-06 14:26:44 +0200
commit538236772ce6edde390079c32533c1e70cf8bdca (patch)
tree1303d22cb092bcf8bb5fadbe4b0ea886eceb1ffa /CMakeLists.txt
parentc953c72c86c281d650b2a8ff856e3d614664e11a (diff)
downloadDictzipQuery-538236772ce6edde390079c32533c1e70cf8bdca.tar
DictzipQuery-538236772ce6edde390079c32533c1e70cf8bdca.tar.gz
DictzipQuery-538236772ce6edde390079c32533c1e70cf8bdca.tar.bz2
DictzipQuery-538236772ce6edde390079c32533c1e70cf8bdca.tar.lz
DictzipQuery-538236772ce6edde390079c32533c1e70cf8bdca.tar.xz
DictzipQuery-538236772ce6edde390079c32533c1e70cf8bdca.tar.zst
DictzipQuery-538236772ce6edde390079c32533c1e70cf8bdca.zip
Implement BASE64 decoding of locations given by dictionary index
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2514635..da53cc3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,10 +13,16 @@ include_directories(
add_library(
DictzipQuery
SHARED
+ src/util/base64.cc
src/istream/stream.cc
src/istream/buffer.cc
)
+target_link_libraries(
+ DictzipQuery
+ z
+)
+
add_executable(
example
example.cc
@@ -25,7 +31,6 @@ add_executable(
target_link_libraries(
example
DictzipQuery
- z
)
install(