aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-04-20 13:09:32 +0200
committerAdrian Kummerländer2014-04-20 13:09:32 +0200
commit29a9fb20b4c8414f2590886e43ae86794a53db89 (patch)
tree4d426d45293a019caee8ee879186111c90b426d3 /CMakeLists.txt
parent3383e24e396431eed7d4ab9f69ff8ffaf12d4925 (diff)
downloadInputXSLT-29a9fb20b4c8414f2590886e43ae86794a53db89.tar
InputXSLT-29a9fb20b4c8414f2590886e43ae86794a53db89.tar.gz
InputXSLT-29a9fb20b4c8414f2590886e43ae86794a53db89.tar.bz2
InputXSLT-29a9fb20b4c8414f2590886e43ae86794a53db89.tar.lz
InputXSLT-29a9fb20b4c8414f2590886e43ae86794a53db89.tar.xz
InputXSLT-29a9fb20b4c8414f2590886e43ae86794a53db89.tar.zst
InputXSLT-29a9fb20b4c8414f2590886e43ae86794a53db89.zip
Implemented support for modifying external function base path
* one expects a read-file function to work relative to the directory the transformation is located and not to the executable's location ** from the perspective of the user the transformation is the application, not the actual executable * removed PlattformGuard struct from TransformerGuard (now TransformerFacade) * TransformerFacade is instatiated with the appropriate relative working path ** i.e. it will have to be instantiated for every directory containing one or more transformations
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 26ff8d1..4421841 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,7 @@ add_executable(
test
test.cc
src/utility.cc
- src/transformer_guard.cc
+ src/transformer_facade.cc
src/function/read_file.cc
src/function/read_xml_file.cc
)