aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-04-19 18:31:15 +0200
committerAdrian Kummerländer2014-04-19 18:31:15 +0200
commit3383e24e396431eed7d4ab9f69ff8ffaf12d4925 (patch)
tree8cedb029eee462dd8145077aee98db593ef6d62d /CMakeLists.txt
parent334efe3383c436d61a8e5dd95b923cb0d5db9652 (diff)
downloadInputXSLT-3383e24e396431eed7d4ab9f69ff8ffaf12d4925.tar
InputXSLT-3383e24e396431eed7d4ab9f69ff8ffaf12d4925.tar.gz
InputXSLT-3383e24e396431eed7d4ab9f69ff8ffaf12d4925.tar.bz2
InputXSLT-3383e24e396431eed7d4ab9f69ff8ffaf12d4925.tar.lz
InputXSLT-3383e24e396431eed7d4ab9f69ff8ffaf12d4925.tar.xz
InputXSLT-3383e24e396431eed7d4ab9f69ff8ffaf12d4925.tar.zst
InputXSLT-3383e24e396431eed7d4ab9f69ff8ffaf12d4925.zip
Implemented transformation execution function
* InputXSLT::PlattformGuard handles xerces and xalan construction and lifetime * InputXSLT::TransformerGuard instantiates PlattformGuard, configurates external functions ** offers execute method for "executing" a XSL tranformation with empty input
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aa6310b..26ff8d1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,7 @@ add_executable(
test
test.cc
src/utility.cc
+ src/transformer_guard.cc
src/function/read_file.cc
src/function/read_xml_file.cc
)