aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-05-20 21:17:10 +0200
committerAdrian Kummerländer2014-05-20 21:17:10 +0200
commit35334241ce4b76b1b1a66219ce938f27fdf39031 (patch)
tree1bad6d46b957e47eac2127f16198876cf7fe8450 /CMakeLists.txt
parent426265b91d4533b7aa16d53124ad9b5d0a6862d6 (diff)
downloadInputXSLT-35334241ce4b76b1b1a66219ce938f27fdf39031.tar
InputXSLT-35334241ce4b76b1b1a66219ce938f27fdf39031.tar.gz
InputXSLT-35334241ce4b76b1b1a66219ce938f27fdf39031.tar.bz2
InputXSLT-35334241ce4b76b1b1a66219ce938f27fdf39031.tar.lz
InputXSLT-35334241ce4b76b1b1a66219ce938f27fdf39031.tar.xz
InputXSLT-35334241ce4b76b1b1a66219ce938f27fdf39031.tar.zst
InputXSLT-35334241ce4b76b1b1a66219ce938f27fdf39031.zip
Replaced FunctionResolveInclude with IncludeEntityResolver
* xalan / xerces offers the possibility of implementing custom entity resolvers which are called upon by "<xsl:include..." ** such a custom resolver was implemented to resolve include path entities * this is a much better way to support include paths than offering a custom external "resolve-include" function * as entity paths are expanded before they are passed to the entity resolver, a special "[path]" syntax simmilar to "#include <path>" had to be implemented
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c5aa8ea..7722264 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,6 +32,7 @@ set(
src/support/filesystem_context.cc
src/support/stylesheet_parameter_guard.cc
src/support/xalan_string.cc
+ src/support/include_entity_resolver.cc
src/support/tuple/xobject_value.cc
src/support/dom/document_cache.cc
src/support/dom/document_cache_item.cc