aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-04-18 19:51:24 +0200
committerAdrian Kummerländer2014-04-18 19:51:24 +0200
commit6dd832dd0adb35f63148a0e7bd5bdcfb28516c3b (patch)
treef0a9709d7d09786585220ff0c27ceae97d7a4b87 /CMakeLists.txt
parente886ac3a4f2dacc79cf174b1257146fd91bf6b7c (diff)
downloadInputXSLT-6dd832dd0adb35f63148a0e7bd5bdcfb28516c3b.tar
InputXSLT-6dd832dd0adb35f63148a0e7bd5bdcfb28516c3b.tar.gz
InputXSLT-6dd832dd0adb35f63148a0e7bd5bdcfb28516c3b.tar.bz2
InputXSLT-6dd832dd0adb35f63148a0e7bd5bdcfb28516c3b.tar.lz
InputXSLT-6dd832dd0adb35f63148a0e7bd5bdcfb28516c3b.tar.xz
InputXSLT-6dd832dd0adb35f63148a0e7bd5bdcfb28516c3b.tar.zst
InputXSLT-6dd832dd0adb35f63148a0e7bd5bdcfb28516c3b.zip
Implemented basic XML reading capabilities
* command "read-xml-file" reads a XML file and allows it to be transformed by the calling XSLT * this will allow workflows like the following: ** a tranformation reads all the markdown files in a directory ** these markdown files are converted to a xml representation by a external function calling a appropriate C++ markdown parser ** the XML representation of each markdown file is converted to XHTML inside the XSL transformation ** ... and embedded into the output XHTML document ** => all inside a single XSL tranformation *** i.e. it is provided with only a empty dummy XML input file and fetches the actual input by itself * as all current code contained within this repository this is just a quick and dirty proof-of-concept and not in any way good code
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e98ef8a..7aadb81 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,7 +3,7 @@ project(InputXSLT)
set(
CMAKE_CXX_FLAGS
- "-std=c++11 -W -Wall -Wextra -Winline -pedantic"
+ "-std=c++11 -W -Wall -Wextra -Winline -pedantic -g"
)
include_directories(