aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-04-21 21:47:20 +0200
committerAdrian Kummerländer2014-04-21 21:47:20 +0200
commit7142544d43b431df44d34921b0f3012fa1e0137d (patch)
tree5fb5de3222d25f0e48f24a0dbdd0d18f5d917c89 /CMakeLists.txt
parentcdf4ad3486debe75fe89b2f04bb62541f3ac8405 (diff)
downloadInputXSLT-7142544d43b431df44d34921b0f3012fa1e0137d.tar
InputXSLT-7142544d43b431df44d34921b0f3012fa1e0137d.tar.gz
InputXSLT-7142544d43b431df44d34921b0f3012fa1e0137d.tar.bz2
InputXSLT-7142544d43b431df44d34921b0f3012fa1e0137d.tar.lz
InputXSLT-7142544d43b431df44d34921b0f3012fa1e0137d.tar.xz
InputXSLT-7142544d43b431df44d34921b0f3012fa1e0137d.tar.zst
InputXSLT-7142544d43b431df44d34921b0f3012fa1e0137d.zip
Implemented basic external directory traversal function
* _read-directory_ lists all files in a given directory ** currently text-only output, xml planned * improved FilesystemContext path resolution (relative path is fully resolved by boost::filesystem)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 43b8e98..915a05d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,6 +16,7 @@ add_executable(
src/transformer_facade.cc
src/function/read_file.cc
src/function/read_xml_file.cc
+ src/function/read_directory.cc
src/support/filesystem_context.cc
)