aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-04-21 13:30:23 +0200
committerAdrian Kummerländer2014-04-21 13:30:23 +0200
commitcdf4ad3486debe75fe89b2f04bb62541f3ac8405 (patch)
treeb09b380ca22abe5678079f86420c748dcd82c70d /CMakeLists.txt
parent5f4f3f003e1f08e5495e0fe30fae18eb6029888d (diff)
downloadInputXSLT-cdf4ad3486debe75fe89b2f04bb62541f3ac8405.tar
InputXSLT-cdf4ad3486debe75fe89b2f04bb62541f3ac8405.tar.gz
InputXSLT-cdf4ad3486debe75fe89b2f04bb62541f3ac8405.tar.bz2
InputXSLT-cdf4ad3486debe75fe89b2f04bb62541f3ac8405.tar.lz
InputXSLT-cdf4ad3486debe75fe89b2f04bb62541f3ac8405.tar.xz
InputXSLT-cdf4ad3486debe75fe89b2f04bb62541f3ac8405.tar.zst
InputXSLT-cdf4ad3486debe75fe89b2f04bb62541f3ac8405.zip
Extracted filesystem path resolution into InputXSLT::FilesystemContext
* this class provides methods for resolving paths relative to the contained base path * other filesystem interaction methods will also be implemented in this class ** for instance directory traversal
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 095480a..43b8e98 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,6 +16,7 @@ add_executable(
src/transformer_facade.cc
src/function/read_file.cc
src/function/read_xml_file.cc
+ src/support/filesystem_context.cc
)
target_link_libraries(