aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-05-26 19:49:44 +0200
committerAdrian Kummerländer2014-05-26 19:49:44 +0200
commit86f8e73299e86b65affc1a71610dd061fa13bf5c (patch)
treee76856cd0f3b07638a4b73c7695014a39523f43a /CMakeLists.txt
parentc5a11763985172f54d0da8a2a2778f882f3656e5 (diff)
downloadInputXSLT-86f8e73299e86b65affc1a71610dd061fa13bf5c.tar
InputXSLT-86f8e73299e86b65affc1a71610dd061fa13bf5c.tar.gz
InputXSLT-86f8e73299e86b65affc1a71610dd061fa13bf5c.tar.bz2
InputXSLT-86f8e73299e86b65affc1a71610dd061fa13bf5c.tar.lz
InputXSLT-86f8e73299e86b65affc1a71610dd061fa13bf5c.tar.xz
InputXSLT-86f8e73299e86b65affc1a71610dd061fa13bf5c.tar.zst
InputXSLT-86f8e73299e86b65affc1a71610dd061fa13bf5c.zip
Revamped external execute function into a external text formatter function
* importing XML output of a called executable into the result document required special logic which clashed with a general execute function * general execute function may be implemented in the future ** support for external text formatters with XML output has a higher priority * current implementation enables calling a markdown parser and including the XHTML output into the document
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 442c215..1943a13 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,7 +28,7 @@ set(
src/function/read_xml_file.cc
src/function/read_directory.cc
src/function/transform.cc
- src/function/execute.cc
+ src/function/external_text_formatter.cc
src/support/filesystem_context.cc
src/support/stylesheet_parameter_guard.cc
src/support/xalan_string.cc