aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Kummerländer2014-05-08 21:16:31 +0200
committerAdrian Kummerländer2014-05-08 21:16:31 +0200
commit947603b5d7f05053a93a3cfe257fa7ab11304a90 (patch)
tree58ed6c641ac0e9f36b0ca6e8d347ab0308e81a51 /CMakeLists.txt
parent209f0b2fd9310f503d4599b12483fddc04d1f7dd (diff)
downloadInputXSLT-947603b5d7f05053a93a3cfe257fa7ab11304a90.tar
InputXSLT-947603b5d7f05053a93a3cfe257fa7ab11304a90.tar.gz
InputXSLT-947603b5d7f05053a93a3cfe257fa7ab11304a90.tar.bz2
InputXSLT-947603b5d7f05053a93a3cfe257fa7ab11304a90.tar.lz
InputXSLT-947603b5d7f05053a93a3cfe257fa7ab11304a90.tar.xz
InputXSLT-947603b5d7f05053a93a3cfe257fa7ab11304a90.tar.zst
InputXSLT-947603b5d7f05053a93a3cfe257fa7ab11304a90.zip
Implemented black-box test cases
* the directories below "./test" contain test cases ** "transformation.xsl" and the expected result as "reference.xml" ** tests are performed by "check.sh" *** returns diff on error * this system enables simple verification of external function results ** way simpler than C++ unit tests would be in this scenario * expanded cmake instructions to automatically execute the test cases * old example transformation was removed
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b6229ca..2171d0f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,3 +47,10 @@ target_link_libraries(
test
${Libraries}
)
+
+add_custom_command(
+ TARGET
+ test
+ POST_BUILD COMMAND
+ cd ../test && ./check.sh
+)